Определение номера квартала по дате

Удобная формула НОМКВАРТАЛА для вычисления номера квартала по дате в Excel.

Описание работы

Функция =НОМКВАРТАЛА служит для определения номера квартала по дате. Можно, конечно, ограничиться стандартными функциями Excel. Сочетание формул ЕСЛИ и МЕСЯЦ также решит эту задачу. Формула получается достаточно громоздкая, а пользовательская функция на VBA проста и понятна.

Стандартными методами проблема решается такой формулой:

=ЕСЛИ(МЕСЯЦ(A1)<4;1;ЕСЛИ(МЕСЯЦ(A1)<7;2;ЕСЛИ(МЕСЯЦ(A1)<10;3;4)))

Синтаксис

Функция =НОМКВАРТАЛА(ДАТА) имеет всего один аргумент:

  • ДАТА - Дата, номер квартала которой необходимо определить.

Пример

Определение номера квартала по дате

Код на VBA

Function НОМКВАРТАЛА(ByVal ДАТА As Date) As Integer
    Dim m As Integer
    m = Month(ДАТА)
    Select Case m
        Case 1 To 3
            НОМКВАРТАЛА = 1
        Case 4 To 6
            НОМКВАРТАЛА = 2
        Case 7 To 9
            НОМКВАРТАЛА = 3
        Case Else
            НОМКВАРТАЛА = 4
    End Select
End Function
Надстройка
VBA-Excel
Надстройка для Excel содержит большой набор полезных функций, с помощью которых вы значительно сократите время и увеличите скорость работы с программой.